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Trademarks 
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the United States and/or other countries. 
 
Other product and company names mentioned herein may be the registered trademarks, trademarks 
or service marks of their respective owners.  
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Information in this document is subject to change without notice and does not represent a 
commitment on the part of the manufacturer. The software described in this document is furnished 
under license agreement or nondisclosure agreement and may be used or copied only in accordance 
with the terms of the agreement. It is against the law to copy the software on any medium except as 
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Overview 

General 

Lpv Creator generates Lpv files that are played back with Lpv Player. 
The Lpv file format is similar to other multi-media formats such as AVI or MPEG. However, a special 
compression procedure allows recording laser shows in very high quality with very small file sizes, 
which is not possible with other formats. 
In order to allow replay without Lpv Player or for further use (e.g. for the creation of demo 
videos), an Lpv file can also be converted into the AVI format. 
 
The software for playing back previously recorded laser shows, called Lpv Player, can be 
downloaded from the LaserAnimation homepage free of charge: 
 

https://www.laseranimation.com/en/customer-area/lasergraph-dsp/lpv-player 
 
 
 
About This Manual 

Before installing Lpv Creator please read the first chapter "Installation" carefully and follow the 
steps described there in correct order. 
 
The second chapter "Lpv Recording - Take One" gives you an overview of the creation of an Lpv file. 
Here the generation of an Lpv file is shown in a few steps, using the included demo show (Lpv 
Trailer) as an example. 
 
In the third chapter "Lpv Creator Reference" all functions of Lpv Creator are explained in detail. 
 
The appendix provides a list of the key combinations (shortcuts) of Lpv Creator. 
 

https://www.laseranimation.com/en/customer-area/lasergraph-dsp/lpv-player
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Installation 

Step 1 – Before Installation 

The latest software version of the LGRemote should be installed on your PC. Your  
Lasergraph DSP should also be running the latest system software (version "2004/06/09" or later). 
Current versions and installation files can be found in the customer area of the LaserAnimation 
homepage:  
 

https://www.laseranimation.com/en/customer-area/lasergraph-dsp. 
 
 
 
Step 2 – Installing Lpv Creator 

If you received Lpv Creator on CD-ROM, please insert this into your CD-ROM drive. The 
installation is started automatically. If you deactivated the Autorun function, you can start the file 
Setup.exe manually if necessary. 
 
When installing the download version, e.g. "LpvCreator--2016-04-22.exe", please execute this file to 
start the installation. 
 
Please execute the installation step by step and remember the directory into which you have 
installed Lpv Creator. In the default installation this is "C:\Program Files\Lpv Creator". There you 
can find examples and documentation, among other things. 
 

 

https://www.laseranimation.com/en/customer-area/lasergraph-dsp
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Step 3 – Activate the Lasergraph DSP for Lpv Creator 

The valid program license is a permanent part of the Mark 2 so an activation code is not 
necessary. 
 
Lpv Creator needs a valid Lpv Creator license on your Lasergraph DSP in order to record and 
convert Lpv files and to create AVI files. You can install Lpv Creator on more than one PC, 
however you can only use it on one PC at a time. 
 
You can use Lpv Creator with more than one Lasergraph DSP, however at least one Lasergraph 
DSP has to have the Lpv Creator license. 
 
Important: 
If you own more than one Lasergraph DSP it is advisable to install the license on the Lasergraph DSP 
that is available most frequently because you cannot create or edit any Lpv files without it. 
 
Now start LGRemote and connect to the desired Lasergraph DSP. 
 
Enter "ApplyLicenseKey" (short: "ALK") in the command line without parameters. 
 

 
 
A key is displayed, the so called "Request-Code": 
 

 
 
Please send this code (here: "1234567") to lpv@laseranimation.com. You will then receive an 
activation code by email. 
 
After receiving the activation code you have to enter this on the Lasergraph DSP to install the license 
for Lpv Creator. Since this code can be very long (approx. 80 characters) we suggest that you do 
not type it in but rather send it to the Lasergraph DSP directly with copy and paste. Select the code 
in your email and then press Ctrl+C. Connect to your Lasergraph DSP with LGRemote.  
Enter "ApplyLicenseKey" (short: "ALK") in the command line and then press Ctrl+V: 
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After confirmation by "ok" (or Return) the Lasergraph DSP should give a reply similar to this: 
 

 
 
Please note that the string of characters displayed after "response=" can differ from the picture 
shown above. Your Lasergraph DSP is now activated for Lpv Creator. 
 
Should you receive "invalid license key" as response, please check the software version of your  
Lasergraph DSP. It should be the most recent version, at least version 2004/06/09. 
 
 
Additional Steps After Installation / Update 

If a restart is necessary after an installation, your system will suggest this. If problems occur when 
Lpv Creator is started for the first time after installation, restart your PC even if this was not 
requested. In some cases this can solve problems. 
On the first start of Lpv Creator it is possible that a so called fog-file is created. During this 
process, data for the 3D fog which is used are calculated. This may take a few minutes, but it only 
happens once. 
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Lpv Recording - Take One! 

Recording a small demo laser show will give you an overview of the way Lpv Creator works.  
 
Preparation 

The installation directory of Lpv Creator contains the subdirectory "Lasergraph DSP". There you 
will find the demo show "LpvTrailer.BOOT". Copy this to a directory which is accessible by the  
Lasergraph DSP over the network. 
 

 
 
Then load this show into the Lasergraph DSP. After loading, the Lasergraph DSP should show its 
main screen. Everything has to be prepared so that the show can be started with "Play 0:00:00,00". 
However, do not start the show yet, Lpv Creator will do this for you. 
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After you have started Lpv Creator (from the start menu: "Programs  Lpv Creator  Lpv 
Creator" or through the icon on your desktop), select your Lasergraph DSP (menu: "File  Select 
DSPs" or press Ctrl+S). Double clicking with the left mouse key connects the Lasergraph DSP to 
Lpv Creator (see chapter "Select Lasergraph DSP"). 
 

 
 
Activate the test picture on your Lasergraph DSP and verify the test pattern is properly displayed in 
Lpv Creator: 
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On the Lasergraph DSP you can now set the Super Preview parameters. These can be found under 
"Advanced Parameters  Super Preview" (see chapter "Super Preview DSP"). 
However, in the example "LpvTrailer" everything is already set correctly. 
 

 
 
You should deactivate the test picture after all settings have been made since this is not supposed to 
be recorded here. 
 
 
 
... And Action! 

You can now record the show by selecting from the menu "File  Record Lpv" (Alt+R). In a dialog 
box you can now specify the Lpv file or overwrite an existing file. You should now see the following 
dialog: 
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Lpv Creator now waits for show data from the Lasergraph DSP. Clicking on the button "Auto" will 
automatically start the show and it will be recorded film by film. 
 
This takes approx. 40 seconds for the little demo show. You can find further information about the 
functions in the chapter "Recording The Lpv File". 
 
When the end of the show is reached the recording will be stopped automatically and you will see a 
dialog box. 
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Lpv Conversion 

 
Since Lpv Creator at first only records the picture data, the audio data must be added afterwards. 
 
The second step, "Lpv Conversion", adds the audio data. You can start the conversion from the 
menu, "File  Convert Lpv" (Alt+C). You should see the following window: 
 

 
 
The quality of the recorded picture can be changed with Quality. A value of 90 provides a very good 
quality. Normally you should leave it at that value because the quality decreases visibly with smaller 
values. 
Limit Fps can be activated to limit the stored pictures per second. 20 fps (frames per second) are 
usually enough to retain a smooth flow of movement. For the first test you can just leave everything 
the way Lpv Creator suggests it. 
 
For adding the audio file activate the checkbox "Edit Audio" and select the audio file with "Browse". 
The audio file "LpvTrailer.wav" belonging to the show LpvTrailer can be found in the installation 
directory of Lpv Creator. 
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Now select this file and determine the quality for the addition of the audio data and the conversion 
of the picture data. 
 
With Preset 5 the sound is encoded in good quality. Stereo sound takes up about 1 MByte per 
minute this way. If a smaller file size is more important than good quality select Preset 3. This will 
make 4 minutes fit into 1 MByte. 
 
Detailed explanations of the parameters can be found in the chapter "Converting The Lpv File". 
 
Then click on Save and confirm the overwriting of the version without sound if necessary (this will be 
replaced by the new one). The first Lpv file is now ready and is played back directly in Lpv Creator. 
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AVI Export 

The Lpv format is ideally suited for presentations and for storage purposes. However, if your 
customers do not have the possibility to install Lpv Player (for instance with other operating 
systems), Lpv files can also be converted into the AVI format. 
 
To open the following window, press Alt+A or select from the menu "File  Save AVI". 
 

 
 
To create an AVI file which will run on most systems, select the "Cinepak Codec". The quality should 
be reduced to 90, otherwise the resulting file will be extremely large. 
For the audio format you will be on the safe side with "PCM". Of course you can also choose other 
codecs as long as they are installed on your system. However, please note that not all codecs are 
available on all systems. Please make sure that you only use codecs that are installed on the systems 
where the AVI file is to be played back or edited. 
 
Then click on "Save" to start the conversion. 
 
Further information regarding the AVI export can be found in the chapter "Generating An AVI File". 
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Lpv Creator Reference 

This chapter describes all functions of Lpv Creator in detail. 
 
 

The Lpv Creator Menu 

Menu – File 

 
 
Open 

Opens one or more Lpv files. (Ctrl+O) 
 
Close 

Closes the currently opened Lpv file. (Ctrl+W) 
 
Close All 

Closes all opened Lpv files. (Ctrl+Del) 
 
Select DSPs 

Opens the dialog window for selecting the Lasergraph DSPs. (Ctrl+S) 
(see chapter "Select Lasergraph DSP") 
 
Record Lpv 

Opens the dialog window for recording a laser show. (Alt+R) 
(see chapter "Recording The Lpv File") 
 
Convert Lpv 

Opens the dialog window for converting Lpv files. (Alt+C) 
(see chapter "Converting The Lpv File") 
 
Write AVI 

Opens the dialog window for creating AVI media files. (Alt+A) 
(see chapter "Generating An AVI File") 
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Exit 

Closes Lpv Creator. (Ctrl+Q) 
 
 
Menu – Edit 

 
 
Cut 

Cuts an inserted background picture and places it in the clipboard. (Ctrl+X) 
 
Copy 

Copies the current picture to the clipboard. (Ctrl+C) 
 
Paste 

Inserts a picture from the clipboard as background picture. (Ctrl+V) 
 
Properties 

Opens the Lpv Creator Properties window. (P) 
(see chapter "Lpv Creator Properties") 
 
Reset to File's Properties 

Returns the settings to the values stored in the Lpv file. If no special settings are stored in the Lpv 
files, the default settings are used. (Ctrl+R) 
 
Reset to Generic Defaults 

Resets the settings to the default values of Lpv Creator. Values that may be present in the Lpv file 
will be ignored. (Ctrl+Alt+R) 
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Menu – View 

 
 
Always On Top 

Lpv Creator is always displayed in the foreground. (Ctrl+T) 
 
Resolutions 

Select a predefined resolution for the Lpv Creator window. (<F2> ... <F11>) 
 
Full Screen 

Toggles between full screen and window display. (Alt+Return) 
 
Caption/Frame 

Toggle the display: 
Standard window  window without menu  window without frame  standard window (Ctrl+M) 
 
Playback Control 

Turn the player at the lower edge of the window on or off. (E) 
 
Infos 

Turn the additional information on or off. If display of the information is activated, the following will 
be displayed: 
At the top of the picture on the left hand side the timecode will be displayed. On the bottom left 
hand side the output frequency of the picture when it is displayed with a laser projector is shown 
(estimate). The display on the bottom right hand side shows how often the simulation on the screen 
is calculated. (I) 
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Menu – Play 

 
 
Play / Pause 

Start / stop the current laser show. (Space bar) 
 
Mute 

Turn the sound output on or off. (M) 
 
Next File 

Switch to the next Lpv file. (Page Down) 
 
Previous File 

Switch to the previous Lpv file. (Page Up) 
 
Beginning 

Player jumps to the beginning of the current Lpv file. (Home) 
 
End 

Player jumps to the end of the current Lpv file. (End) 
 
Forward 

Wind forward within the current Lpv file. (→) 
 
Backward 

Rewind within the current Lpv file. (←) 
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Fast Forward 

Fast forward within the current Lpv file. (Ctrl+→) 
 
Fast Backward 

Fast rewind within the current Lpv file. (Ctrl+←) 
 
Next Frame 

Jump to the next picture of the current Lpv file. (Ctrl+Alt+→) 
 
Previous Frame 

Jump to the previous picture of the current Lpv file. (Ctrl+Alt+←) 
 
 
Menu – Special 

 
 
Visualization  

Opens a dialog where the visualization of the laser preview in a visualization software can be turned 
on or off and where the projectors can be assigned to the virtual laser devices within the 
visualization. 
The Lpv Creator supports "LightConverse", "Depence V:3D", "Capture", "Realizzer 3D" and 
"wysiwyg" as visualization software. 
 
 
Send NetTimecode 

Turn the output of Net-Timecode over the network on or off. 
The Net-Timecode can be used to synchronize one or more Lasergraph DSP to an Lpv.  
 
 
Sync to NetTimecode 

When enabled the playback of an Lpv file will be synchronized to incoming Net-Timecode. 
 
Notes: 

• As long as the playback is synchronized to external Net-Timecode audio output is disabled. 
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Super Preview 

Overview 

In order to determine the way in which a laser show will be displayed on the screen (for instance as 
graphic or as a beam show) you should adjust the Super Preview Parameters on the Lasergraph DSP 
accordingly. You will find the dialog under "Advanced Parameters" in the main screen of the 
Lasergraph DSP. For each set of output parameters there is a corresponding set of parameters for 
the Super Preview. This way it is for instance possible to set different values for film 1 ( e.g. for a 
graphic display) than for film 2 (which may be showing beam effects). 
There are several parameters that can be adjusted in Lpv Creator itself, but these are always 
effective for all films/DSPs simultaneously. We suggest that you set the parameters on the Lasergraph 
DSP whenever possible and only change the values in Lpv Creator for specific occasions. Look at 
the values in Lpv Creator as a way to adjust the display afterwards (after a show has been 
recorded). 
 
Here is an overview of the parameters that can be adjusted directly on the Lasergraph DSP: 
 

 
 
 
Scanner 1 & Scanner 2 

Number of scanners generating an output. If two scanners are activated they display an identical 
picture mirrored along the Y-axis. 
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Graphics 

By activating this parameter, the laser picture is displayed as a graphic. If "Fog" is turned off this is 
equivalent to a graphics projection onto a screen. Together with "Fog" the effect is more one of a 
gauze installed between the point of view and the scanner. 
"Intensity" is used to adjust the brightness of the graphic. Higher values result in brighter lines. 
"Size" influences the size of the picture, where the X- and Y sizes can be adjusted separately or 
simultaneously by keeping the mouse button depressed on the "&"-symbol and dragging. 
"Position" is used to set the position of the picture. Here it is also possible to set the X- and Y 
positions separately or simultaneously using "&". 
 
Fog 

If you activate this parameter, the virtual room fills with fog. This then floats in clouds through your 
preview picture. "Intensity" sets the brightness of the fog. The values can range from barely visible fog 
(0.1) to completely filled areas. With "Position" you determine the position of the scanners. X- and Y 
positions can be set separately or simultaneously ("&"). 
 
Beam Detection 

If this parameter is activated, the Super Preview performs an automatic beam detection. This means 
that points which have repeats will be displayed as bright lines. The "Intensity" of the lines can be set. 
The parameter "Repeat" determines the number of repeats necessary to display a line as a "beam". 
 
Beam Table 

By activating this parameter beams from the beam table will be simulated. Two predefined options 
are available: A beam table for 8 positions and one for 20 positions. 
"Intensity" determines how clearly the beams will be accentuated. 
 
 
Scanner Rating 

Allows simulation of different types of scanners. 
 
 
Reset 

Resets all parameters to their default values. All changes will irrevocably be lost. 
 
Copy 

Copies all parameter values to the clipboard. This will be available until the Lasergraph DSP is turned 
off / restarted. 
 
Paste 

Inserts the parameter values from the clipboard into the current Super Preview set. This will 
overwrite old settings irrevocably. 
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Lpv Creator Properties 

Overview 

The Lpv Creator properties allow modifying the display of the show loaded on the Lasergraph DSP 
resp. the current Lpv file. 
Temporary changes of the graphic or beam output can be made here. This is also used to modify the 
intensity and type of fog, fine tune your graphics card settings or add background images. 
 
The Lpv Creator properties window is reached by selecting from the menu "Edit  Properties" or 
using the shortcut P. 
 

 
 
Default, Load and Save 

 
"Reset all Parameters to default (As defined by Lpv File)" 
The first icon from the left sets all parameters to the values defined in the Lpv file. 
 

 
"Reset all Parameters to default (Ignore Lpv Parameters)" 
The second icon from the left resets all parameters to the Lpv Creator default values. Settings 
stored in the Lpv file are ignored. 
 

 
"Load Parameters from File" 
Opens the dialog box for opening the current settings. These can be exchanged at will between 
LGPreview, Lpv Player and Lpv Creator. 
 

 
"Save current Parameters to File" 
Opens the dialog box for saving the current settings. This way you can reuse a setting later without 
the trouble of adjusting all values again. The background pictures are also saved with all settings. 
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Properties – Main 

 
 
Overview 

Except for the "Line Width", all values here correspond to the settings that you can also make on the 
Lasergraph DSP (Super Preview). However, these values are always effective for all channels. We 
recommend that you only change the Lpv Creator values in special circumstances, for instance if 
you want to change something after the recording. Normally you should set the parameters on the 
Lasergraph DSP because this is more flexible and values can be set individually for each channel. Use 
the Lpv Creator values for example to add some fog to a graphic show afterwards: 
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Some checkboxes can have three states: default, active, inactive. The setting of the properties refers 
to the parameters of the super Preview of the same name. "Graphics" in Lpv Creator is equivalent 
to the setting "Graphics" in the Super Preview of the Lasergraph DSP. 
Input fields are marked in yellow if the current setting is not the default value. This lets you see at a 
glance which values you have changed. You can reset each field individually to its default value with 
Ctrl+D. 
 

 
Default. The value specified in the Super Preview of your Lasergraph DSP is used here.  
 

 
Active. Activating the setting. The setting made in the Super Preview is ignored. 
 

 
Inactive. Deactivating the setting. The setting made in the Super Preview is ignored. 
 
Some values are effective in addition to the settings made on the Lasergraph DSP. 
 
 
Line Width 

This parameter can only be adjusted on the PC. The value specifies the line width of the graphic in 
pixels. The default value of 2.0 usually results in the best quality. With full screen display and high 
resolution, wider lines may result in a better picture. It may also be better to set wider lines (2.5 to 
3.0) if a conversion to AVI or video is planned. 
Unfortunately not all graphics cards support arbitrary adjustment of the line width. 
 
Graphics 

By activating this parameter, the laser picture is displayed as a graphic. If "Fog" is turned off this is 
equivalent to a graphics projection onto a screen. Together with "Fog" the effect is more one of a 
gauze installed between the point of view and the scanner. 
"Intensity" is used to adjust the brightness of the graphic. Higher values result in brighter lines. 
"Size" influences the size of the picture, where the X- and Y sizes can be adjusted separately or 
simultaneously by keeping the mouse button depressed on the -symbol and dragging. With 
"Position" you determine the position of the picture. Here X- and Y positions can also be set 
separately or simultaneously with . 
 
Fog 

If you activate this parameter, the virtual room fills with fog. This then floats in clouds through your 
preview picture. "Intensity" sets the brightness of the fog. The values can range from barely visible fog 
(0.1) to completely filled areas. With "Position" you determine the position of the scanners. X- and Y 
positions can be set separately or simultaneously ( ). 
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Beam Detect 

If this parameter is activated, the Super Preview performs an automatic beam detection. This means 
that points which have one or more repeats will be displayed as bright lines. The "Intensity" of the 
lines can be set. The parameter "Repeat" determines the number of repeats necessary to display a 
line as a "beam". 
 
Beam Table 

By activating this parameter beams from the beam table will be simulated. Two predefined options 
are available: A beam table for 8 positions and one for 20 positions. 
"Intensity" determines how clearly the beams will be accentuated. 
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Properties - Fog 

 
 
Overview 

Here you set the details of the fog. These settings are only done on the PC. Please note that you 
need a fast graphics card with OpenGL support to achieve optimal graphics display. 
 
 
True 3D Fog 

Activating True 3D Fog makes the display of the fog even more realistic. However, this is not 
supported by all graphics cards. Under certain circumstances it is also possible that even though it 
does work the calculation is very slow. 
 
Structure 

The structure of the fog can be set on a range from unstructured (Haze, 0.0) to a clear, defined, 
structured display (1.0). 
 
Clouds 

Changes the number of clouds from no clouds (0.0) to many, clearly defined clouds (1.0). 
 
Speed 

The speed with which the clouds float through your virtual showroom can be set. Here the value 0 
means that the clouds do not move. 
 
Direction 

Define the direction in which the virtual clouds will move. 
 
Rotate 

This parameter lets the clouds rotate around the Z-axis. 
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Properties – OpenGL Setup 

 
 
Overview 

In this section you have the possibility to set OpenGL parameters. The standard configuration usually 
leads to the best display. In individual cases it may be possible to improve or accelerate the output by 
optimizing these parameters for your graphics card. Lpv Creator analyses your configuration and 
tries to determine the optimal settings. These are referred to as System Default. If you find a better 
configuration, you can save this so that it is automatically activated the next time Lpv Creator is 
started. This is referred to as Default. 
 
 
Force generic OpenGl driver 

This parameter activates the software OpenGL driver by Microsoft® Windows®. Only use this if 
display errors occur. In practice this driver is very slow and it may take several seconds for a picture 
to be calculated. 
 
Enhanced Line Drawing 

When this parameter is activated the lines are drawn in a special mode. With some graphics cards 
this will improve the display. 
 
Beam Profile 

Lines are not cut sharply at the edges, they have a profile. This looks a little more realistic. Only 
works if "Enhanced Line Drawing" is activated. 
 
Polygon Smoothing 

When this option is supported by the graphics card the picture usually looks clearer and so called 
steps are avoided. This option usually does not make the display slower if it is supported by the 
graphics card. It is therefore superior to the "Global Scene anti-Aliasing" which you may find in the 
setup of your graphics card. Here it also depends on the graphics card if the picture is actually 
improved. 
 
True 3D Fog 

see chapter "Properties - Fog" (Parameter "True 3D Fog") 
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Load Defaults 

Stored default values concerning the OpenGL setup are loaded.  
 
Save As Defaults 

The current OpenGL configuration is saved as default configuration. 
 
Reset To System Default 

The OpenGL configuration is reset to the values detected by Lpv Creator. 
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Properties – Background 

 
 
Overview 

You can integrate up to four background pictures, logos or watermarks into your preview. Accepted 
file formats are JPEG or PNG (PNG = Portable Network Graphics). 
Another possibility for adding pictures to your Lpv file is to copy the desired picture to the clipboard 
from a graphics editing software with Ctrl+C and to then add it to Lpv Creator as a background 
picture or logo with Ctrl+V. Pictures added this way will however be integrated into the Lpv file as 
uncompressed bitmap graphics (BMP files). The Lpv file may get very large this way. It is therefore 
advisable to convert bitmap graphics into the JPEG or PNG format first in order to save disk space. 
 
 
Load 

Activate this checkbox to display the specified background picture. Clicking on the button "Load" will 
open a selection box where you can choose a graphic. 
 
Intensity 

Specify the intensity / brightness of the background picture. It often makes sense to reduce the 
intensity of background pictures or watermarks so that they will not interfere with the laser 
simulation. 
 
Size 

Specify the size with this parameter. 
 
Position 

This parameter determines the position of the background picture. Usually background pictures will 
be oriented toward the center. At +/-10 you can also "affix" the pictures to one of the edges. 
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Select Lasergraph DSP 

 
 
Overview 

In this window you select the Lasergraph DSPs which will be the sources of the shows you want to 
record. You can select more than one Lasergraph DSP, but the first one has to have a valid license 
for Lpv Creator. 
 
 
Available Lasergraph DSPs 

Lists all available Lasergraph DSPs. 
 
Add 

Add the selected Lasergraph DSP from the list "Available Lasergraph DSPs". 
 
Remove 

Remove the selected Lasergraph DSPs from the list "Selected Lasergraph DSPs". 
 
Remember 

Lpv Creator saves the selected Lasergraph DSPs and reestablishes the connection automatically at 
restart. 
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Recording The Lpv File 

Overview 

The recording is always the first step in the creation of an Lpv file. Before the recording can begin 
you have to select a destination file. You can either enter this as a file name or select an existing Lpv 
file to be overwritten. 
When the recording window is opened, the name of the show currently loaded on the Lasergraph 
DSP will be entered as the default file name. 
 
Select "Save" to get to the recording. The recording window is opened and Lpv Creator is ready to 
record. 
 
You can record a show either manually or automatically. It is usually advisable to record shows 
automatically because Lpv Creator will then perform all required operations. 
 
Clicking on the button "Auto" will start the automatic recording. If you have a Lasergraph DSP 
workstation with more than one DSP card, Lpv Creator now selects the fastest output card for the 
recording. Shows with more than one output, e.g. graphic show on film 1 and beam show on film 2, 
will be recorded separately film by film. Each film will be displayed by the card selected by Lpv 
Creator. This multi pass method makes it possible to record multi scanner shows even from a 
Lasergraph DSP compact. And on a workstation the amount of data generated is limited to one 
channel to avoid overflowing the network connection. 
Before you start automatic recording, the Lasergraph DSP has to be in root mode and the loaded 
show must be one that can be started with "Play 0:00:00,00". The timecode has to be ended 
automatically in the script, otherwise Lpv Creator will not recognize the end of the show and will 
continue running. 
If you want to add sound later you have to keep in mind that the audio track is always inserted at 
1:00:00,00. If necessary, adjust the timescript accordingly. 
 
If using the automatic mode is not possible, for instance when recording interactive shows or games, 
you can also start the show yourself on the Lasergraph DSP. You then have to end the recording 
manually in Lpv Creator. If the show normally runs without a script (film is started by Run), we 
suggest that you use a simple script so you can establish the timecode. (If a show is started with Run, 
the timecode is undefined from the point of view of Lpv Creator.) 
 
Important: 
The laser output is deactivated during the automatic recording. For safety reasons you should not 
activate the laser output on the Lasergraph DSP during the recording, because all films contained in 
the show, beam- as well as graphics shows, are displayed by the same DSP card. 
After the automatic recording is finished, the state of the show is reset to the original state, i.e. the 
state before the recording. 
During the recording it is advisable to leave the display in the preview window disabled 
so that it does not interfere with the recording, causing unwanted interruption. 
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Destination 

Name and directory of the Lpv file into which the laser show is recorded. 
 
Timecode 

Current timecode of the show which is to be recorded. 
 
Channels 

Number of films recorded so far. 
 
Images 

Number of pictures recorded so far. 
 
Size 

Current size of the Lpv file during recording. The file can get quite large during recording because 
the data are initially stored without compression. After the recording is finished the file size will be 
reduced by the built-in compression. 
 
Show output while recording 

Display of the laser show during the recording. Should only be used on fast systems because 
otherwise the recording may be disturbed. 
 
Stop 

Ends the manual or automatic recording of a show. The part recorded so far will be saved. 
 
Auto 

Starts the automatic recording of a show. This only works if the show has already been loaded and 
the Lasergraph DSP is in the main screen. The show has to be one that can be started with "Play 
0:00:00,00". If sound is to be added, the actual show should be synchronized to 1:00:00,00. If 
necessary, adjust the timescript accordingly (for example with Retime). 
See the timescript of the included example "LpvTrailer.BOOT"! 
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Converting The Lpv File 

Overview 

The conversion of an Lpv files serves different purposes. One application is converting a recorded 
Lpv file to add sound. Another application is to create lower quality versions of an existing Lpv file by 
reducing the quality, the frame rate or the audio quality (e.g. for internet download).  
A conversion is also necessary to embed background pictures. 
 

 
 
Source 

Name and directory of the Lpv file that is to be converted. 
Directly after a recording the name of the most recently recorded Lpv file is displayed in this field. 
To convert another file, open the dialog box using the button "Browse". 
 
Destination 

Name and directory of the Lpv file that is to be written. 
You have to enter a file here. If you leave this field empty and click "Save" to start the conversion, 
you will be prompted to enter a destination file. 
If an Lpv file is entered at "Source", the same name and directory will automatically be entered here. 
"Source" and "Destination" may be identical, the current file will then be overwritten with the new 
version. 
If you want to change this, open the corresponding dialog box with the button "Browse". 
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Quality 

Value of the picture quality (0 ... 100). 
This value sets the picture compression for the Lpv file. 90 results in a good quality. Usually you 
should leave it at this value. Smaller values will result in smaller files, however the quality will 
decrease visibly. In most cases it is better to reduce the frequency (fps) because this is usually less 
disturbing subjectively than reducing the quality here. 
 
Limit Fps 

At first all pictures are recorded into the Lpv file without limitation. In individual cases this may have 
the result that 50 or more pictures are saved per second. Usually this will not be an advantage. 
Therefore you can limit the number of pictures saved per second with "Limit Fps". You will see 
practically no difference at 20-25. If you want to reduce the file size even further, you can also try 10 
or 15. 
Do not use this option if you plan to convert to interlaced AVI or use at least twice the target 
frames per second, e.g. use 60 for 30 fps NTSC video. 
 
Embed current display parameters 

The set preview parameter values are saved in the Lpv file. We do not usually recommend this. It is 
usually better to set the "Super Preview" parameters correctly on the Lasergraph DSP before the 
recording. 
However, if you want a show to be displayed differently from the way it was recorded, you may 
modify Lpv Creator's parameters and save (embed) the values into the Lpv file. 
 
Update background bitmaps 

Save background pictures in the Lpv file. It is possible to integrate up to four background pictures 
into an Lpv file in the preview parameters (see chapter "Properties - Background"). However, these 
will only be integrated with the Lpv file if you explicitly activate this here. 
 
Edit Audio 

Adding / replacing the integrated audio file. 
Activate this parameter if you want to replace an existing audio file or integrate an audio file into an 
Lpv file. 
When this parameter is activated you can access the following parameters. 
 
Replace 

Adding or replacing existing audio files. 
If an Lpv file does not have sound yet, activate this parameter and click the button "Browse" to select 
an audio file. Supported audio formats are WAV and OggVorbis. Deactivate this parameter if you 
only want to change the audio settings for the sound already existing in the Lpv file. 
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Resample 

Changing the sample frequency of the audio file. (1000 Hz ... 96000 Hz) 
Activate and change this parameter in order to integrate the audio file into the Lpv file with a sample 
frequency of your choice. As a rule a higher frequency will result in better quality. Here you can for 
instance reduce the size of a file sampled with 44100 Hz by reducing the frequency to 22050 Hz. Of 
course this will also reduce the quality. 
 
Mono 

When this parameter is activated, the audio file will be saved in mono (one-channel audio). This will 
usually reduce the file size at the cost of a reduced quality. 
 
Quality 

The audio quality controls the performance of the compression. With higher values the quality will 
increase, but so will the size of the file. 
For a good quality choose 4, higher values will hardly improve the result. This is equivalent to an 
average of 1MByte per minute (with 44100 Hz, stereo). 
If you want to reduce the size of the file at the cost of the quality, reduce the value accordingly. This 
value is closely linked to bps, because a higher quality also leads to a higher data rate and vice versa. 
 
bps 

Data rate in bits per second (bps). Determines how many bits per seconds are to be used for the 
sound. This value is closely linked to quality, because a higher data rate leads to a higher quality (and 
vice versa). 
 
Adjust Length of Lpv file by Audio 

During recording, the beginning and end of the Lpv file are determined according to the first/last 
picture. However, sometimes the sound starts before the first picture or does not end with the last 
picture. When you activate this option the sound will be analyzed and if necessary the beginning and 
the end will be extended. 
 
Protect 

Protects your Lpv file against further changes. A protected Lpv file can then not be altered in any 
way. It also cannot be converted into an AVI file. Existing background pictures such as watermarks or 
copyrights cannot be removed. Please bear in mind that the protection cannot be removed from a 
file in any case, not even by yourself! 
 
Note: 
 
To prevent misuse of your Lpv files, add a logo or watermark to your Lpv file (see chapter "Lpv 
Creator Properties") and then save it with "Protect". 
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Generating An AVI File 

Overview 

An AVI file describes a multimedia file containing audio and video data. However, if an AVI file is 
recorded or converted in high quality, its size can get very large in contrast to the size of the Lpv 
files. It may still make sense to convert an Lpv file into an AVI file, for instance to allow further use in 
a video program. 
 
If you want to record your laser shows on video later (DV, MPEG or the like), you should take into 
account the specific aspect ratios and resolutions. Picture points (pixels) on computer monitors are 
usually square shaped. This is not true for PAL or NTSC displays. 
Therefore special aspect ratios have to be considered to prevent distortions. Lpv Creator has two 
predefined settings with correct aspect ratios and resolutions for PAL (720x576, 25fps, 54:59) and 
NTSC (720x480, 29.97fps, 11:10). 
This will distort the display on the computer monitor, however display in PAL or NTSC will be 
correct this way. Prepare everything so that display is correct on the computer monitor. Then press 
Alt+F1 to adjust for PAL, or Alt+Shift+F1 for NTSC. 
 
To open the AVI dialog select from the menu File  Write AVI. In the dialog you can control 
explicitly which codec will be used to encode the video and audio files. 
Clicking "Save" will start the generation of the AVI file. 
A progress display will inform you of the estimated time for the conversion. If you have activated 
"Play AVI when done", the AVI file will be played back automatically at the end. 
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Lpv 

Name of the Lpv file which is to be converted into an AVI file.  
 
Avi 

Name and directory of the AVI file which is to be created. 
After an Lpv file is selected, this field contains the name of the AVI file. The same name and path is 
used automatically with the file suffix for AVI files. 
 
Suppress Infos while creating AVI 

During playback of an Lpv file additional information is displayed, for instance the time code. You will 
normally not want this information to also be part of the AVI file. With this option the display of this 
information can be suppressed when generating the AVI file (default setting). 
 
Fps 

Frame rate in frames per second (0.1 ... 120 frames per second). 
Set the desired frequency here. The European television standard PAL is set at 25 frames per second, 
the American television standard NTSC uses 29,97 frames per second. If you only want to play back 
the file on a computer you can usually decide at will which frame rate is the right one for your 
purpose. 20 Hz are usually sufficient to let movements appear smooth. 
 
Interlaced 

Enable this option to create interlaced AVI files for later recording on DV or conversion into DVD 
format. This improves quality for playback on TV devices. 
 
Upper fields first 

Determines the order of the half pictures when creating interlaced AVI files. DV always uses "lower 
field first". 
 
Codec 

Here you select the codec which is used to compress the picture data in the AVI file. You can also 
select "<Uncompressed DIB>". The data will then be saved without compression. This may make 
sense when you want to process the file further. However, the files will get very large this way. 
Which video codecs are available for selection here depends on the installation of your system. The 
"Cinepak Codec" is almost always available. This codec will not result in the best quality, but AVI files 
generated with this codec can be played back on almost any Windows® system. 
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Configure 

Opens the dialog box for configuration of the selected codec. For information about this see the 
documentation of the codec. Not all codecs support this method of configuration. 
 
About 

Opens the About box of the selected codec (displays information about producer and version). Not 
supported by all codecs. 
 
Keyframe every "x" Frames 

Enforcing keyframes. Support depends on the codec. Modern codecs reduce the data quantity by 
only saving the changes in comparison to the previous picture (most of the time only part of the 
picture changes). In contrast, keyframes do not need information about neighboring pictures. This 
takes up more disk space, but without keyframes a file could only be played back from the start. 
Jumping in (e.g.) in the middle of the complete film would no longer be possible. It is therefore 
advisable to enforce keyframes at least at certain intervals. For instance, a value of 250 is equivalent 
to one keyframe every 10 seconds (at 25 fps). 
If a film is to be processed further, for instance in a video editing program, it makes sense to choose 
even smaller values here so that the pictures can be addressed faster. 
A value of 1 means that every picture is encoded as a keyframe. Depending on the codec, this will 
make the files substantially larger. 
 
Quality 

Quality of the video (0 ... 100). This value can be entered directly into the input field or adjusted 
using the slider underneath. The exact effect depends on the codec. The value is a dimension of the 
quality with which the pictures are encoded. 100 is the best quality, 0 the worst. In general files with 
higher quality will be larger. Which subjective quality the value 100 is equivalent to depends on the 
codec. With some codecs, quality 100 is equivalent to the quality of the original material, with 
others, a distinct reduction of quality is visible even with quality 100. 
 
Datarate 

Setting a specified data rate in kBits/second. 
Activate the checkbox and enter a corresponding value to change the data rate. Not all codecs 
support a limitation of the data rate and the exact relevance also depends on the codec. 
  
Audio-Format 

Setting the audio codec. Just as with the picture, there are also many different compression methods 
and formats for the sound. The PCM format is always supported. With this, the data is saved without 
compression. The additional selection options again depend on which audio codecs are installed on 
your system. 
Please note that some codecs are displayed but do not support all formats. It is also possible that 
codecs are displayed in the list even though they are not activated for encoding. An error message 
may be displayed when you try to start generating an AVI file with such a codec. In this case select 
another format and try again. 
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If you want to make absolutely sure that you will be able to play back the AVI file, you should stick to 
the PCM format. More efficient codecs may be frequent, but they are not available on all systems. 
 
Variant 

Setting the quality with which a codec encodes the audio data. The exact options available here 
depend on the selected format. Lpv Creator tries to select a variant which comes as close as 
possible to the original material in the Lpv file. However, you may be able to reduce the file size by 
accepting a lower quality. 
 
Status 

Display of the current frames/second, the elapsed time and the remaining time during the conversion 
into AVI files. 
The status is displayed during the generation of an AVI file. By activating the checkbox "Details" all 
parameter settings are displayed. However, changes to the parameters are no longer possible at this 
moment. 
 
Overwrite 

Automatic overwriting of an existing AVI file. 
 
Play AVI when done 

Playing back the AVI file after completion. The player which is associated with AVI files on your PC 
will be used for playback. 
 
Save 

Starts the generation of the AVI file. 
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The following is the copyright notice for libogg and libvorbis, which are included in this software: 
 
Copyright (c) 2002, Xiph.Org Foundation 
 
Redistribution and use in source and binary forms, with or without modification, are permitted 
provided that the following conditions are met: 
 
• Redistributions of source code must retain the above copyright notice, this list of conditions and 

the following disclaimer. 
 
• Redistributions in binary form must reproduce the above copyright notice, this list of conditions 

and the following disclaimer in the documentation and/or other materials provided with the 
distribution. 

 
• Neither the name of the Xiph.Org Foundation nor the names of its contributors may be used to 

endorse or promote products derived from this software without specific prior written 
permission. 

 
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" 
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE 
ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR 
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL 
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS 
OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER 
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY 
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGE. 
 

  



Version 2022/05/10 Manual Lpv Creator  

 
 

 

LaserAnimation Sollinger GmbH    Crellestrasse. 19/20    D-10827 Berlin 
Phone  +49 (30) 780 963 00    Fax  +49 (30) 780 963 25 
Email  info@laseranimation.com    Internet  http://www.laseranimation.com 
 
Copyright © LaserAnimation Sollinger GmbH. All rights reserved. 

Page 44 

Release Notes 

 
Version 2022/05/10 

The maximum number of visualization channels has been increased from 8 to 16. 
 
Bugfix: The Beam Detection produced incorrect lines in combination with the DisplayZone 
commands. 
 
Some bugs and security issues within the 3rd-party libraries have been fixed. 

 
 
 
Version 2021/04/20 

With multi-pass recording, up to 32 channels can now be recorded. 
 
"Sync to NetTimecode" no longer requires a license. 
 
Improved compatibility with Windows 10. 
 
Some bugs and security issues within the 3rd-party libraries have been fixed. 

 
 
 
Version 2019/12/16 

Some bugs and security issues within the 3rd-party libraries have been fixed. 
 
 
 
Version 2016/04/22 

"Sync to NetTimecode" now supports Net Timecode with 50fps and 60fps. 
 
Bugfix: When using "Sync to NetTimecode" with 24fps and 30fps the playback position was 
sometimes inaccurate. 
 
Some bugs and security issues within the 3rd-party libraries have been fixed. 
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Version 2015/08/28 

In connection with the DisplayZone commands output errors could occur. 
 
Bugfix: Under certain circumstances the fog data were created again each time the program was 
started. 
 
Some bugs and security issues within the 3rd-party libraries have been fixed. 

 
 
 
Version 2015/06/01 

Minor changes. 
 
 
 
Version 2015/05/18 

New predefined resolution 1920x1080 has been added to the menu "View". 
 
 
 
Version 2015/02/27 

Support for the new parameter "Auto Maximize" in the Super Preview Setup. 
 
The quality of the visualization in "LightConverse" has been improved. 

 
 
 
Version 2014/11/21 

The Lpv Creator can now be used as source for the visualization software "wysiwyg". 
 
Bugfix: The connection to a Lasergraph DSP was refused when the network name of the 
Lasergraph DSP contained parentheses. 

 
 
 
Version 2014/04/08 

Minor changes, e.g.: 
 New menu item "Play"  "Stop". 
 New shortcut to exit the program: Ctrl+Q. 
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Version 2014/03/21 

New installer solves compatibility issues with the 64-bit editions of Windows®. 
 
Under certain conditions it could happen that the Visualization dialog did not open. 

 
 
 
Version 2013/12/10 

The Lpv Creator can now be used as source for the visualization software "Realizzer 3D". 
 
"Sync to NetTimecode" now supports Net Timecode with 24fps, 30fps and 100fps. 
 
Bugfix: Under certain conditions the playback of LPV files with large background images could 
cause a crash on slow computers. 
 
Redraw issues under CrossOver with "Mac driver" enabled have been solved. 

 
 
 
Version 2013/09/27 

The quality of the visualization in "Depence V:3D" has been improved. 
 
New predefined resolutions have been added to the menu "View". 

 
 
 
Version 2013/09/09 

The maximum number of visualization channels has been increased from 4 to 8. 
Furthermore individual channels can now be turned off. 
 
The redraw issue within the window frame under Wine has been solved. 

 
 
 
Version 2013/02/22 

Some Wine related issues have been solved. 
 
The quality of the visualization in "Capture Polar" has been improved. 
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Version 2012/11/13 

The Lpv Creator can now be used as source for the visualization software "Depence V:3D" and 
"Capture Polar". 
 
Using the new function "Sync to NetTimecode" it is possible to synchronize the playback of an 
Lpv file to incoming Net-Timecode. 
 
Visualization now works when the Lpv Creator is minimized. 

 
 
 
Version 2012/07/13 

The Lpv Creator can now be used as source for the visualization software "LightConverse". 
 
Using the new function "Send NetTimecode" it is possible to send the current timecode as Net-
Timecode over the network. 
 
Bugfix: The progress bar did not work correctly with very large Lpv files. 

 
 
 
Version 2011/11/17 

The Lpv Creator now supports different scanner types according to the setting in the Super 
Preview Setup of the Lasergraph DSP. 

 



Version 2022/05/10 Manual Lpv Creator  

 
 

 

LaserAnimation Sollinger GmbH    Crellestrasse. 19/20    D-10827 Berlin 
Phone  +49 (30) 780 963 00    Fax  +49 (30) 780 963 25 
Email  info@laseranimation.com    Internet  http://www.laseranimation.com 
 
Copyright © LaserAnimation Sollinger GmbH. All rights reserved. 

Page 48 

Appendix 

Shortcuts for Menus 

Function Menu Shortcut 
Open File File => Open Ctrl+O 
Close File => Close Ctrl+W 
Close All File => Close All Ctrl+Entf 
Select DSPs File => Select DSPs Ctrl+S 
Record Lpv File => Record Lpv  Alt+R 
Convert Lpv File => Convert Lpv Alt+C 
Write AVI File => Write AVI Alt+A 
Exit File => Exit Ctrl+Q  /  Alt+F4 
   
Cut Edit => Cut Ctrl+X 
Copy Edit => Copy Ctrl+C 
Paste Edit => Paste Ctrl+V 
Properties Edit => Properties P 
Reset to File's Properties Edit => Reset To File's Default Ctrl+R 
Reset to Generic Defaults Edit => Reset To Generic ... Ctrl+Alt+R 
   
Always On Top View => Always On Top Ctrl+T 
Resolution 720x576 (PAL)  Alt+F1 
Resolution 720x480 (NTSC)  Alt+Shift+F1 
Resolution 320x240 View => 320x240 F2 
Resolution 640x480 View => 640x480 F3 
Resolution 800x600 View => 800x600 F4 
Resolution 1024x768 View => 1024x768 F5 
Resolution 1280x800 View => 1280x800 F6 
Resolution 1280x1024 View => 1280x1024 F7 
Resolution 1440x900 View => 1440x900 F8 
Resolution 1600x1200 View => 1600x1200 F9 
Resolution 1920x1080 View => 1920x1080 F11 
Full Screen View => Full Screen Alt+Return 
Caption/Frame View => Caption/Frame Ctrl+M 
Playback Control View => Playback Control E 
Infos View => Infos I 
   
Play / Pause Play => Play/Pause Space 
Mute Play => Mute M 
First File  Ctrl+PageUp 
Last File  Ctrl+PageDown 
Next File Play => Next File PageDown 
Previous File Play => Previous File PageUp 
Beginning  Play => Beginning Home 
End Play => End End 
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Forward Play => Forward → 
Backward Play => Backward ← 
Fast Forward Play => Fast Forward Ctrl+→ 
Fast Backward Play => Fast Backward Ctrl+← 
Next Frame Play => Next Frame Ctrl+Alt+→ 
Previous Frame Play => Previous Frame Ctrl+Alt+← 
   
Manual Help => Manual F1 
 
 
 
Shortcuts for Properties 

Function Name of Property Parameter  Shortcut 
   
Line Width + Line Width L 
Line Width - Line Width Shift+L 
Graphic + Graphics Intensity G 
Graphic - Graphics Intensity Shift+G 
Fog + Fog Intensity F 
Fog - Fog Intensity Shift+F 
 

 

 

Command Line Parameters 

The Lpv Creator can be started from the command line or from a shortcut with the following 
parameters:  
 
 LpvCreator.exe [<options>] [<lpv-file> …] 
 
Options:  
 

-f starts the Lpv Creator in full screen mode 
-o plays the specified Lpv file once and quits the application when finished 
-t opens the program window with high priority (always on top)  

 

Lpv File: 
 

One or more Lpv files can be specified. They will be opened automatically. 
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